Hei module /injectors

Moderators: Regional Representative, Technical Advisor

Post Reply
dnw3576
POC Newbie
Posts: 10
Joined: Thu Feb 02, 2017 9:53 am
Year: 1983
Model: trans am
Engine: 305
Name: Darren Walker
Location: WEST BROMWICH
Contact:

Hei module /injectors

Post by dnw3576 » Fri May 08, 2020 3:18 pm

Hi members, I am having an issue getting my firebird started, I have an 83 daytona 500 firebird with the 305 lu5 crossfire injection, s code, been trying to track down the issue that is preventing the engine from firing to life, got fuel to both injectors but no squirt , got spark, according to the manual the problem should be down to bad hei module, is there any way to verify the module is broken? , tested pin 2 on the ecu to dizzy (pulse reference) no short or cut, is there any thing else other than the module that can stop the injectors firing? Also at the rear of the engine I got a black square connector labelled wire 2 on one side and wire 3 on the other side, off the connector is a black wire with a loop terminal, looks like a ground, is it?, many thanks and best wishes for your time to respond
You do not have the required permissions to view the files attached to this post.

User avatar
cowboy1sf
POC Ultimate Poster
Posts: 1761
Joined: Sat Mar 28, 2009 11:10 am
Membership No: 20-440
Year: 2001
Model: TA WS6
Engine: 350
Name: Steve Fullam-Cowboy
Location: Guildford Surrey
Location: Guildford Surrey
Contact:

Re: Hei module /injectors

Post by cowboy1sf » Sat May 23, 2020 3:38 am

Hi, give Robin a call on; 07904 183302


GET OFF MY LAWN!!
{BIG C}
Owner of the Black Pimpernel

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests